Magento auf joomla100.com
« am: 19.01.2010 20:27 Uhr »
Hallo Leute,
ich möchte testweise gerne eine Magentoshop auf meinem Webspace hier bei joomla100.com (best provider ever) laufen lassen. Leider erhalte ich immer einen 500er Fehler (Rechte sind alle auf 755 und 644 gesetzt) ... wenn ich die .htaccess auf htaccess.txt umbenenne komme ich in der Installation weiter habe jedoch später (eigene Errfahrung) Probleme mit dem Updates von Magento. Deshalb will ich bei einer neuen Installation diesmal gleich mit der .htaccess arbeiten.

Der Fehler kann im Normalfall nur noch an der .htaccess von Magento liegen bzw. an Befehlen, die ich auskommentieren muß damit das bei joomla100.com läuft

Ich stelle hier mal ganz mutig meine .htaccess zur Verfügung, in der Hoffnung, das jemand die Fehlerquelle vielleicht sehen kann.

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options
#   Options -MultiViews
## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting
    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file
    DirectoryIndex index.php
<IfModule mod_php5.c>
############################################
## adjust memory limit
#   php_value memory_limit 64M
    php_value memory_limit 128M
    php_value max_execution_time 18000
############################################
## disable magic quotes for php request vars
   php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized
   php_flag session.auto_start off
############################################
## enable resulting html compression
## php_flag zlib.output_compression on
###########################################
# disable user agent verification to not break multiple image upload
  php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects
  php_flag zend.ze1_compatibility_mode Off
</IfModule>
<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload
    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>
<IfModule mod_deflate.c>
############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip
    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript
    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html
    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip
    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>
<IfModule mod_ssl.c>
############################################
## make HTTPS env vars available for CGI mode
    SSLOptions StdEnvVars
</IfModule>
<IfModule mod_rewrite.c>
############################################
## enable rewrites
#    Options +FollowSymLinks      <------ Beides mit "#" und ohne versucht
#    RewriteEngine on        <--------------------- DITO HIER
############################################
## you can put here your magento root folder
## path relative to web root
    #RewriteBase /magento/
############################################
## workaround for HTTP authorization
## in CGI environment
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
############################################
## always send 404 on missing files in these folders
    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
############################################
## never rewrite for existing files, directories and links
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
############################################
## rewrite everything else to index.php
    RewriteRule .* index.php [L]
</IfModule>
############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead
    AddDefaultCharset Off
    #AddDefaultCharset UTF-8
<IfModule mod_expires.c>
############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires
    ExpiresDefault "access plus 1 year"
</IfModule>
############################################
## By default allow all access
    Order allow,deny
    Allow from all
############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags
    #FileETag none

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re:Magento auf joomla100.com
« Antwort #1 am: 19.01.2010 21:59 Uhr »
Im Grunde muss einfach alles auskommentiert werden, da auf unseren Servern aus Sicherheitsgründen kein Umschreiben der Serverdirektiven erlaubt ist, z.B.

php_flag session.auto_start off

oder

php_value memory_limit 128M
php_value max_execution_time 18000

geht beides gar nicht, usw.

Hier müsste überall eine # davor gesetzt werden, aber dann ist es gleichbedeutend mit dem Umbenennen in htaccess.txt.

Das Problem beim Update dürfte sicherlich sein, dass dann folgende Einstellungen nötig sind:

php_value memory_limit 128M
php_value max_execution_time 18000

Und das könnte man dann evtl. für ein Update (was hoffentlich nicht so häufig vorkommt) entsprechend setzen, aber das muss durch uns nach Rücksprache geschehen und kann nicht auf Dauer so gesetzt werden. Hier wäre die Frage, welche dieser Einstellungen Magento genau für ein Update benötigt.

Viele der Einstellungen, die hier von der .htaccess auf dem Server geändert werden sollen, sind ohnehin schon standardmäßig so eingestellt, aber eben nur, was auch vernünftig bzw. sicher ist.

Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Re:Magento auf joomla100.com
« Antwort #2 am: 19.01.2010 22:09 Uhr »
Hallo Ekki,

dann werde ich mal umbenennen, macht vielleicht auch nichts bzw werde ich alles auskommentieren. Bei meines Testversuchen mit der htaccess.txt früher konnte ich das Update dann auch machen. Wir schauen mal. Gerne werde ich meine Erfahrungen hier posten, da ich persönlich immer noch von einem großen Potential von Magento ausgehe.