*

Offline JoLic

  • *
  • 82
    • Profil anzeigen
    • JoLichter.de
Plesk mit LetsEncrypt
« am: 21.12.2017 20:59 Uhr »
Hi, eine Frage zum neuen Plesk und LetsEncrypt-Zertifikat.

Wenn ich auf "Let's Encrypt" klicke kommt anstatt dem Assistenten nur diese Meldung:
Warnung: SSL/TLS support is disabled for malbergweich.de.
To resolve the issue, please enable to SSL/TLS support ("Websites & Domains" > "Hosting Settings") for this domain and try again.

In den Hosting-Einstellungen ist SSL/TLS-Unterstützung aus und lässt sich nicht aktivieren.

Unter "Konto" und "Zusätzliche Services" ist der Schalter "Let's Encrypt" aus und lässt sich auch nicht aktivieren.

Fehlt da noch die Freigabe dazu?

Gruß jolic
« Letzte Änderung: 24.12.2017 01:21 Uhr von JoLic »
Das ROCKT!
CMS: MODX REVOLUTION auf Joomla100!
OS: KDE neon

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Plesk mir LetsEncrypt
« Antwort #1 am: 21.12.2017 21:09 Uhr »
LetsEncrypt ist jetzt aktiviert, klappt es jetzt besser?
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline JoLic

  • *
  • 82
    • Profil anzeigen
    • JoLichter.de
Re: Plesk mit LetsEncrypt
« Antwort #2 am: 21.12.2017 21:24 Uhr »
Leider nein, sehe aber das im Konto -> Zusätzliche Services der Schalter "Let's Encrypt" nun aktiviert ist.

Es kommt immer noch diese Warnung und kein Assistent.
« Letzte Änderung: 24.12.2017 00:53 Uhr von JoLic »
Das ROCKT!
CMS: MODX REVOLUTION auf Joomla100!
OS: KDE neon

*

Offline JoLic

  • *
  • 82
    • Profil anzeigen
    • JoLichter.de
Re: Plesk mit LetsEncrypt
« Antwort #3 am: 21.12.2017 21:29 Uhr »
mhh, in der linken Navigation habe ich nun ein "Security Advisor", damit scheint es zu gehen. Teste das...

Bingo, so funktioniert es.

Danke!
« Letzte Änderung: 24.12.2017 00:53 Uhr von JoLic »
Das ROCKT!
CMS: MODX REVOLUTION auf Joomla100!
OS: KDE neon

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Plesk mir LetsEncrypt
« Antwort #4 am: 22.12.2017 08:19 Uhr »
Na immerhin.  ;) Da sind jetzt noch einige Baustellen, tut mir leid wegen der ganzen Umstände. Aber ich bin immer noch überzeugt, dass es besser ist, jetzt mal in den sauren Apfel zu beißen, dafür dann aber auch ein ordentliches Kundenpanel zu haben.

Das ist ja wirklich Gold gegenüber Confixx...
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline JoLic

  • *
  • 82
    • Profil anzeigen
    • JoLichter.de
Re: Plesk mit LetsEncrypt
« Antwort #5 am: 23.12.2017 00:11 Uhr »
Das ist ja wirklich Gold gegenüber Confixx...

So ist es  8)

Falls sich jemand wundert:
Plesk legt in der Domain temporär den Ordner .well-known an. Dort befinden sich die zur Validierung des SSL-Zertifikats nötigen Daten.
« Letzte Änderung: 24.12.2017 00:53 Uhr von JoLic »
Das ROCKT!
CMS: MODX REVOLUTION auf Joomla100!
OS: KDE neon

Re: Plesk mit LetsEncrypt
« Antwort #6 am: 10.01.2018 14:19 Uhr »
Meine Seiten haben nun https und laut Google Chrome hätte ich ein gültiges Zertifikat, aber https wird trotzdem nicht grün. Und ich bekomme dauernd Mails für meine Domains a la:

"Could not secure domains of Fionn Große (login webXXX) with Let's Encrypt certificates. Please log in to Plesk and secure the domains listed below manually.
Securing of the following domains has failed:

[...]

 * 'fionn-gorilla.de'
   Invalid response from https://acme-v01.api.letsencrypt.org/acme/new-reg.
   Details:
   Type: urn:acme:error:rateLimited
   Status: 429
   Detail: Error creating new registration :: too many registrations for this IP"

Das ich es nun händisch machen soll, irgendwie das habe ich zwischen den Zeilen gelesen, aber was genau ich machen soll verstehe ich noch nicht.
Bin für Hilfe dankbar!

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Plesk mit LetsEncrypt
« Antwort #7 am: 10.01.2018 16:23 Uhr »
Das betrifft das Limit von LetsEncrypt. Diese Woche wurde wohl das Limit von 20 pro Woche über eine IP erreicht:

https://letsencrypt.org/docs/rate-limits/

D.h. nächste Woche dürfte es wieder klappen.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline JoLic

  • *
  • 82
    • Profil anzeigen
    • JoLichter.de
Re: Plesk mit LetsEncrypt
« Antwort #8 am: 10.01.2018 20:52 Uhr »
Zitat
gültiges Zertifikat, aber https wird trotzdem nicht grün

Hi, sieht aus als ob dein WP den html-codes parst, z.B.:
src="http://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg"oder
href="http://fionn-gorilla.de/ueber-mich/"
Kann mich auch irren, aber du nutzt keine relative Verweise?

Ich füge deshalb in meinen Templates immer eine base-Element ein und benutze nur relative Verweise.
Bei dir müsste dann im Template head ein
<base href="https://fionn-gorilla.de/">stehen. Dann könntest du relative urls benutzen z.B.:
src="wp-content/uploads/2016/02/halloichbinfionn.jpg"
Das passt dann immer  ;D

jolic
« Letzte Änderung: 10.01.2018 20:55 Uhr von JoLic »
Das ROCKT!
CMS: MODX REVOLUTION auf Joomla100!
OS: KDE neon

Re: Plesk mit LetsEncrypt
« Antwort #9 am: 15.01.2018 12:43 Uhr »
sorry Jolic für die späte Antwort! Ich dachte ich bekomme eine Mail, wenn eine Antwort reinkommt. Danke für die schnelle Antwort!

Die Limits pro Woche sind dann für den ganzen Server auf dem meine Seite läuft, also für alle Kunden die auf kundenserverXX laufen?

Spannend ist ja, dass die eingebundenen Bilder, die nicht über relative Pfadangaben eingebunden sind, sondern über "http://" jetzt mit einem grünen "https://" angezeigt werden. zB https://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg Liegt es daran, dass LetsEncrypt schon paar Zertifikate rausgegeben hat, und der Rest der Webseite mit der Zeit dann nachzieht?

Gerne füge ich auch die Base ein und mache dann die relativen Pfade. Welches Problem kann ich damit umgehen?

Danke!

*

Offline JoLic

  • *
  • 82
    • Profil anzeigen
    • JoLichter.de
Re: Plesk mit LetsEncrypt
« Antwort #10 am: 15.01.2018 18:59 Uhr »
Zitat
sorry Jolic für die späte Antwort! Ich dachte ich bekomme eine Mail, wenn eine Antwort reinkommt. Danke für die schnelle Antwort!
kein Problem, hast du die Checkbox "Bei neuen Antworten benachrichtigen" angeklickt?

Zitat
Die Limits pro Woche sind dann für den ganzen Server auf dem meine Seite läuft, also für alle Kunden die auf kundenserverXX laufen?
keine Ahnung -> Admin?

Vorweg: Ich kenne mich mit WP nicht aus, sehe aber diese "Schönheitsfehler" im Quellcode und daher ist manches nicht so grün wie es sein sollte  8)

Zitat
Spannend ist ja, dass die eingebundenen Bilder, die nicht über relative Pfadangaben eingebunden sind, sondern über "http://" jetzt mit einem grünen "https://" angezeigt werden. zB https://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg Liegt es daran, dass LetsEncrypt schon paar Zertifikate rausgegeben hat, und der Rest der Webseite mit der Zeit dann nachzieht?
nein, in deinem Quelltext steht z.B. "http://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg" und deshalb ist das Schloss auf deiner Startseite nicht grün. Wenn du dir das Bild anzeigen lässt, leitet der Server das zu HTTPS um (siehe Einstellung: "Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS"). Den Quellcode (was also dein WP parst) kann und darf LetsEncrypt nicht einfach ändern.

Zitat
Gerne füge ich auch die Base ein und mache dann die relativen Pfade. Welches Problem kann ich damit umgehen?
wenn du dich mit deinem Template nicht auskennst, lass es besser sein  ;)

Ich erstelle meine Templates selbst und weiß daher wo ich ansetzen muss.
An deiner Stelle würde ich im HTML-Quellcode die "http://" Bereiche suchen und dann die Ursache in deinem WP Backend beheben.
Da das kein Joomla100 oder LetsEncrypt Problem ist - könntest du nach Lösungen evtl. auch in WP Foren suchen?


jolic

Das ROCKT!
CMS: MODX REVOLUTION auf Joomla100!
OS: KDE neon

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Plesk mit LetsEncrypt
« Antwort #11 am: 16.01.2018 09:39 Uhr »
Zitat
    Die Limits pro Woche sind dann für den ganzen Server auf dem meine Seite läuft, also für alle Kunden die auf kundenserverXX laufen?

keine Ahnung -> Admin?
So verstehe ich zumindest den Hinweis von LetsEncrypt zur Fehlermeldung, die basswort hier gepostet hat.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Re: Plesk mit LetsEncrypt
« Antwort #12 am: 16.01.2018 13:23 Uhr »
Danke JoLic und Admin für die Hinweise und Tipps!

Jetzt hat alles geklappt und ich konnte, nachdem ich händisch alle http Links und Bildereinbettungen in https umgewandelt habe, alles mit einem grünen https im Browser einfärben :)

Viiielen Dank!