*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
1. Leeren Sie folgende Tabellen mit phpMyAdmin auf der Datenbank:

jos_users
jos_core_acl_aro
jos_core_acl_groups_aro_map per phpmyadmin

2. Führen Sie auf der Datenbank als SQL-Query folgendes aus:

INSERT INTO `jos_users` VALUES (62, 'Administrator', 'admin', ' email@meinedomain.de Diese E-Mail Adresse ist gegen Spam Bots geschützt, Sie müssen Javascript aktivieren,
damit Sie es sehen können ', '21232f297a57a5a743894a0e4a801fc3', 'Super Administrator', 0, 1, 25, '2006-01-21 17:30:00', '0000-00-00 00:00:00', '', '')
INSERT INTO `jos_core_acl_aro` VALUES (10,'users','62',0,'Administrator',0)
INSERT INTO `jos_core_acl_groups_aro_map` VALUES (25,'',10);

Danach können Sie sich als User "admin" mit dem Passwort "admin" wieder anmelden.

Quelle: http://www.joomla.de/content/blogsection/7/66/
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Habe das gleiche Problem. Habe die Tabellen wie beschrieben geleert und in der Datenbank das SQL-Query ausgeführt erhalte jedoch folgende Meldung:

MySQL meldet: 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO `jos_core_acl_aro` VALUES (10,'users','62',0,'Administrator',0)
INS' at line 2

HILFEEEEEE!!!!

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Notfalls müssten Sie eine Installation lokal anlegen, z.B. mit XJ!, dort die Tabellen jos_users und alle mit jos_core_acl exportieren und die entsprechenden Tabellen auf dem Server damit überschreiben. Danach sollte der Login mit den gleichen Daten wie auf der lokalen XJ!-Installation funktionieren. Vorher darauf achten, dass beide Joomla-Installationen die gleiche Version sind.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline liether

  • *
  • 139
  • Bernd
    • Profil anzeigen
    • Uetersen Badminton
Hallöchen,

hattest Du die Kommandos der Reihe nach ausgeführt?
Jedes "Insert" für sich?

Gruß
Bernd

Hallo,
nachdem ich alle drei Tabellen geleert hatte und in SQL-Query ausgeführt habe (habe dies einzeln der Reihe nach und auch auf einmal versucht) erscheint mir folgende Fehlermeldung:
-----------------------------------------------------------------------------------------------
Fehler
SQL-Befehl:

INSERT INTO `jos_users`
VALUES ( 62, 'Administrator', 'admin', ' email@meinedomain.de Diese E-Mail Adresse ist gegen Spam Bots geschützt, Sie müssen Javascript aktivieren,
damit Sie es sehen können ', '21232f297a57a5a743894a0e4a801fc3', 'Super Administrator', 0, 1, 25, '2006-01-21 17:30:00', '0000-00-00 00:00:00', '', '' )
INSERT INTO `jos_core_acl_aro`
VALUES ( 10, 'users', '62', 0, 'Administrator', 0 )
INSERT INTO `jos_core_acl_groups_aro_map`
VALUES ( 25, '', 10 )

MySQL meldet: 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO `jos_core_acl_aro` VALUES (10,'users','62',0,'Administrator',0)
INS' at line 2

-----------------------------------------------------------------------------------------------


Was mache ich nun wieder verkehrt?

Grüße, 13ir101

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Ich hab es jetzt auch nochmal versucht, gleiches Ergebnis. Scheinbar haben die Jungs von Joomla.de da etwas geschludert, was das SQL-Statement gibt.... :(
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Und wie geht´s jetzt weiter?
Ich wäre wirklich dankbar wenn ich bald wieder an meiner Webseite weiter arbeiten könnte.

Grüße

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Notfalls lokal mit XJ eine Joomla-Installation aufsetzen und die User-Tabelle dort exportieren und auf dem Server die User-Tabelle löschen und dort die User-Tabelle von XJ importieren.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Kann ich hierzu eine detailierte Beschreibung bekommen was ich hierzu alles zu tun habe.
XJ installieren auf dem Rechner ist klar aber dann...??? Wo und wie finde ich die User Tabelle auf dem Server? Muss ich eine neue Tabelle anlegen? ....viele Fragen die nach Antworten lechzen.

Danke im Voraus!

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Im XJ gibt es ja auch einen phpMyAdmin. Dort müssten Sie sich einloggen, auf Exportieren klicken und nur die jos_user Tabelle exportieren. Diesen Dump müssten Sie dann auf dem Webserver importieren, nachdem dort die jos_user Tabelle im phpMyAdmin gelöscht wurde.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Also nun hab ich auch versucht mit XJ! die jos_user Tabelle hochzuladen was auch funktioniert hat aber einloggen kann ich mich dennoch nicht. Habe auch eine andere jos_user Tabelle die ich aus einem anderen Projekt habe versucht aber auch hier komme ich zum gleichen Ergebnis.

Beim Versuch mich im Backend einzuloggen kommt nun diese Fehlermeldung:

JAuthentication::__construct: Could not load authentication libraries.

Also was kann ich noch tun?

*

Offline liether

  • *
  • 139
  • Bernd
    • Profil anzeigen
    • Uetersen Badminton
Hallöchen...,

eventuell fehlt Dir in der Datenbank unter "jos_Plugins" das „Authentication – Joomla“ Plugin
oder es ist auf „unpublished“ gesetzt. Mit PHPMyAdmin wieder auf "published" (1) setzen, oder
Plugin installieren.


Gruß
Bernd
« Letzte Änderung: 18.02.2008 21:39 Uhr von liether »

OK das gute zuerst: Ich kann mich wieder Anmelden :)

Das "jos_plugins" war tatsächlich auf unpublished gesetzt (warum auch immer!?!)
Jedoch wurden nun gar keine User mehr erkannt.
Anschließend habe ich die "jos_plugins", `jos_users`, `jos_core_acl_aro`, `jos_core_acl_groups_aro_map` neu aus XJ installiert.
Ergebnis: Keine User wurden erkannt (auch nicht "admin")

Erst als ich die "jos_plugins", `jos_users`, `jos_core_acl_aro`, `jos_core_acl_groups_aro_map`
aus einer ganz anderen existierenden Installation importiert habe gings auf einmal wieder!?!

Was soll man davon nun halten ???

ABER: "ENDE GUT ALLES GUT"   ;D

Danke für Eure Unterstützung!

Grüße, 13IR101 Bert.

Wie komme ich in diese Datenbank phpAdmin? Habe mein Superadmin verloren, als ich ohne eingeloggt zu sein einfach nur auf "Passwort vergessen" kam. Superadmin wurde daraufhin gelöscht, aber kein neues Passwort zugesandt?! 

Wie komme ich in diese Datenbank phpAdmin? Habe mein Superadmin verloren, als ich ohne eingeloggt zu sein einfach nur auf "Passwort vergessen" kam. Superadmin wurde daraufhin gelöscht, aber kein neues Passwort zugesandt?!