*

Offline jus

  • *
  • 8
    • Profil anzeigen
Restore Site
« am: 26.07.2007 09:37 Uhr »
Hallo zusammen,

ich bin gerade am umziehen und bekomme meine joomla site nicht ans laufen.
- neues Verzeichnis
- subdomain auf das Verzeichnis setzen
- Joomla installieren

Dann hab ich eine laufende joomla Installation - alles schön.

- DB einspielen - geht ohne Fehler zu werfen.
(müsste doch auch gehen eine neue zu erzeugen und in configuration.php den dbnamen und -prefix zu ändern, oder?)
- Backup der Filesystemstruktur einspielen.

Funktioniert nicht - ich bekomme das "temporarely down" angezeigt und das war's.

Wo könnte mein Denkfehler sein?

Ich hab schon kräftig gesucht aber noch keine HowTo gefunden, wie man eine komplette joomla Site restored - vielleicht steht's ja doch irgendwo, für einen Link wär ich sehr dankbar.


Tschau

JUS

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #1 am: 26.07.2007 11:42 Uhr »
Sorry, aber wenn hier von Joomla-Installation und dann von DB einspielen die Rede ist werde ich nicht ganz schlau draus, ob es sich um eine Neuinstallation handelt oder einen Umzug einer bestehenden Installation.

Temporarely down bedeutet, keine Verbindung zur Datenbank.

Es gibt 4 verschiedene Variablen in der configuration.php, die angepasst werden müssen:

dbHost: localhost
user: webxy (Benutzername für die Datenbank)
db: usr_webxy_1 (Name der DB, falls DB über Confixx angelegt wurde)
password: das von Ihnen vergebene Passwort, welches beim Anlegen der ersten DB von Confixx automatisch vergeben wird.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #2 am: 26.07.2007 13:31 Uhr »
Hallo,

es ist eine bestehende Site, die auf joomla100 umziehen soll.
Ich hab den kompletten Abzug per ftp und die DB.....

JUS
« Letzte Änderung: 26.07.2007 13:36 Uhr von jus »

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #3 am: 26.07.2007 13:52 Uhr »
Und wo genau hakt es jetzt? Seite noch immer offline? Dann liegt es an einer der vier o.g. Variablen.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #4 am: 26.07.2007 14:14 Uhr »
Wenn ich das wüsste.....

Das Problem ist auch, dass es richtig viel Daten sind (in der zoom gallerie, so ca 100 MB)

Die hin_und_her Kopiererei ohne shell-Zugriff gestaltet sich etwas schwierig, auf der shell würd ich mir die Daten halt direkt von der andderen Site ziehen......

Ich hab jetzt eine laufende "blanke" Joomla laufen (http://pma.jusch.eu/)
Die laufende Site ist an alter Stelle unter http://www.polymorph-art.com zu sehen.

Ich wollte halt den Umzug testen und wenn die Site unter pma.jusch.eu läuft, die Domain polymorph-art umbeantragen und auf jusch.eu/pma zeigen lassen.

Bloss möcht ich sie erstmal am laufen haben.....

JUS
« Letzte Änderung: 26.07.2007 14:33 Uhr von jus »

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #5 am: 26.07.2007 17:19 Uhr »
Wie bereits per Mail angeboten einfach die DB durchschicken, die Daten per FTP hochladen und den Rest übernehmen wir. Wenn die DB bereits importiert ist, dürfte es keine Probleme mit der Anpassung der Config geben, wie gesagt, es kann sich nur um einen Fehler in einer dieser 4 Variablen handeln.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #6 am: 27.07.2007 10:06 Uhr »
Das wäre äußerst nett! :)
Daten hab ich per PN geschickt......

Gruss, JUS

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #7 am: 01.08.2007 22:23 Uhr »
Hallo,

habt Ihr meine PN mit den Daten bekommen?
Oder klappt die "Reaktivierung" nicht?


Tschau

JUS

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #8 am: 02.08.2007 02:03 Uhr »
MIST, sorry. PMs können im Ticket-System nicht zugewiesen werden, daher ging das vergessen. Könnten Sie bitte bitte nochmal eine Mail schicken, damit das auch wirklich klappt. Dickes Sorry nochmal...
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #9 am: 02.08.2007 08:10 Uhr »
Eine Mail - an welche Adresse?

Gruss

JUS

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #10 am: 02.08.2007 10:49 Uhr »
support at joomla100.com
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #11 am: 03.08.2007 14:47 Uhr »
Herzlichen Dank für Ihre freundliche und kompetente Unterstützung!

Jetzt möcht ich aber trotzdem gern wissen, wie die Verfahrensweise ist (und wo mein Fehler war).


Tschau

JUS

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #12 am: 03.08.2007 19:45 Uhr »
Noch nichts gefunden? ;)
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline jus

  • *
  • 8
    • Profil anzeigen
Re: Restore Site
« Antwort #13 am: 03.08.2007 20:00 Uhr »
Noch nichts gefunden? ;)

 ???
Wie meinen? Noch nichts in der portierten Site gefunden oder meinen Fehler beim portieren?

Das Passwort funktioniert übrigens nicht  :(

Tschau

JUS

*

Offline admin

  • *****
  • 6.311
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Restore Site
« Antwort #14 am: 04.08.2007 16:04 Uhr »
Folgende Parameter sind beim Umzug anzupassen:

$mosConfig_host = 'localhost';
$mosConfig_user = '##user##';
$mosConfig_password = '##password##';
$mosConfig_db = 'usr_##user##_X';
$mosConfig_dbprefix = 'mos_'; (oder jos_)
$mosConfig_absolute_path = '/home/www/##user##/html'; (oder /var/www/....)
$mosConfig_live_site = 'http://www.##ihredomain.de##';
$mosConfig_cachepath = '/home/www/##user##/html/cache'; (oder /var/www/##user##/html/cache)

Gehen wir davon aus, dass ein Kunde den Benutzernamen web1 hat und das Backup der Datenbank in eine über das Kundenmenü angelegte Datenbank importieren möchte, die den Namen usr_web1_1 hat und das Passwort "joomla100", die Seite wird im Ordner /html aufgespielt, wären die obigen Variablen mit folgenden Werten zu ersetzen (Die Domain im Beispiel nennen wir http://www.joomla100.com)

##user## = web1
X = 1 für die erste Datenbank, die im Kundenmenü angelegt wurde
##password## = joomla100
##ihredomain.de## = joomla100.com


Hier waren einfach einige der Variablen in ihrer Konfigurationsdatei noch nicht richtig angepasst, und die Datenbank war nicht richtig importiert.

Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung