Lesbare URLs auf Joomla100 nicht möglich
« am: 20.05.2007 18:34 Uhr »
Hallo!

Ich beschäftige mich gerade mit Drupal und finde es soweit ganz interessant (auch wenn es zu meinen Bedürfnissen nicht so gut paßt wie Joomla); allerdings habe ich festgestellt, daß ich auf Joomla100-Servern keine lesbaren URLs (in Joomla-Sprache: SEF-URLs) erstellen kann - vermutlich wegen deaktiviertem mod_rewrite-Modus. Ist das richtig, daß es daran liegt - oder hat es eine andere Ursache?

Ich benutze Drupal 5.1
Gruß, Orpheus

*

Offline driet

  • *****
  • 732
  • Volle Kanne, Hoschi!
    • Profil anzeigen
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #1 am: 20.05.2007 19:04 Uhr »
Keine Ahnung, hab das aktuelle Drupal 4 laufen und SEF ist für mich nicht interessant gewesen bisher.

Vielleicht probier ich's die Tage mal durch.

Aber schön, dass ich nicht der einzige Drupaltester bin hier  ;D
« Letzte Änderung: 20.05.2007 19:59 Uhr von driet »
Problemlösungswahrsager, Glaskugelmethode

*

Offline driet

  • *****
  • 732
  • Volle Kanne, Hoschi!
    • Profil anzeigen
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #2 am: 20.05.2007 19:20 Uhr »
Hab's grad mal eingestellt bei mir, in der 4er Version gehts ohne Probleme:

http://pk.driet.de/node/4

Hast du die .htaccess angepasst mitlaufen? Könnte mir vorstellen, dass die erforderlich ist.
Problemlösungswahrsager, Glaskugelmethode

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #3 am: 20.05.2007 19:45 Uhr »
Also mod_rewrite ist definitiv aktiv, sonst würde es ja auch bei Joomla nicht funktionieren. Kann es sein, dass die neueren Versionen mit suPHP keine lesbaren URLs erstellen können?
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #4 am: 21.05.2007 00:45 Uhr »
@driet

Was du da auf deiner Seite hast, sind allerdings keine lesbaren URLs - oder hast du die schon wieder abgestellt?

Die htaccess habe ich nicht mitlaufen - während der Installation machte sie Probleme. Aber ich habe deine Anpassung gesehen und probiere das mal. Danke!

@admin
Ich habe auf der Drupal-DVD von Video2Brain gesehen, daß es mit der 5er-Version funktioniert. Wenn es mit der htaccess nicht klappt, muß es eigentlich an der Serverkonfiguration liegen.
Gruß, Orpheus

*

Offline driet

  • *****
  • 732
  • Volle Kanne, Hoschi!
    • Profil anzeigen
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #5 am: 21.05.2007 01:24 Uhr »
Du meinst userfriendly URLs über das path-Modul?

Manuelles URL-Umbenennen funktioniert ohne Probleme:

http://pk.driet.de/about
http://pk.driet.de/links
« Letzte Änderung: 21.05.2007 01:32 Uhr von driet »
Problemlösungswahrsager, Glaskugelmethode

Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #6 am: 23.05.2007 11:05 Uhr »
Unter Drupal 4.7.6 hab ich es jetzt auch hinbekommen - nicht aber unter Drupal 5.1. Die Anpassung der .htaccess unter 4.7.6 (Auskommentieren der PHP4 und PHP5-Blöcke) funktioniert unter Drupal 5.1 nicht. Da läuft dier Seite bislang nur ohne die .htaccess. Ich werde mal etwas experimentieren, ob ich die Konfiguration der .htaccess so hinbekomme, daß Drupal 5.1 mit .htaccess und lesbaren URLs läuft.
Gruß, Orpheus

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #7 am: 23.05.2007 12:31 Uhr »
Gibt es in 5.1 auch sowas wie #Option FollowSymlinks oder ähnliches? Das müsste auch auskommentiert werden.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline driet

  • *****
  • 732
  • Volle Kanne, Hoschi!
    • Profil anzeigen
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #8 am: 23.05.2007 15:03 Uhr »
.htaccess, Original, Drupal 5.1


#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "(\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?
!! Manueller Umbruch !! |xtmpl)|code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On
  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600
  # Do not cache dynamically generated pages.
  ExpiresByType text/html A1
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the prefix www. you
  # can use one of the following settings to force user to use only one option:
  #
  # If you want the site to be accessed WITH the www. only, adapt and
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule .* http://www.example.com/ [L,R=301]
  #
  # If you want the site to be accessed only WITHOUT the www. prefix, adapt
  # and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule .* http://example.com/ [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory and
  # the rewrite rules are not working properly.
  #RewriteBase /drupal

  # Rewrite old-style URLs of the form 'node.php?id=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
  #RewriteRule node.php index.php?q=node/view/%1 [L]

  # Rewrite old-style URLs of the form 'module.php?mod=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
  #RewriteRule module.php index.php?q=%1 [L]

  # Rewrite current-style URLs of the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
</IfModule>

# $Id: .htaccess,v 1.81 2007/01/09 09:27:10 dries Exp $
« Letzte Änderung: 23.05.2007 15:05 Uhr von driet »
Problemlösungswahrsager, Glaskugelmethode

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #9 am: 23.05.2007 15:20 Uhr »
Das dürfte daran liegen, dass die ganzen Servereinstellungen durch die .htaccess überschrieben werden sollen, was der Server aber nicht mag.

 php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0

Sowas z.B. geht nicht, die Einstellungen dürfen nicht überschrieben werden.
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

froggy

Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #10 am: 23.08.2007 12:07 Uhr »
bedeutet das, dass man die Drupal 5.2 Version nicht unter joomla100 zum laufen bekommt?

bzw. lesbaren URLs?

Diese wären für mich sehr wichtig.
oder muss man bei den besagten Werten einfach mit "#" davor auskommentieren, damit 5.2 und URL Umwandlung klappt?

php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0


« Letzte Änderung: 23.08.2007 12:09 Uhr von froggy »

*

Offline admin

  • *****
  • 6.302
  • Support Joomla100
    • Profil anzeigen
    • 100 Prozent Joomla-Hosting
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #11 am: 23.08.2007 12:55 Uhr »
Mit einer Raute davor sollte es eigentlich klappen. Ohne Auskommentierung funktioniert es nicht?
Vollkasko-Versicherung für Ihre Homepage?
http://www.joomla100.com/service/vollkasko-versicherung

*

Offline driet

  • *****
  • 732
  • Volle Kanne, Hoschi!
    • Profil anzeigen
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #12 am: 24.08.2007 11:22 Uhr »
Ich hab bei meiner .htaccess umfangreich ausgeklammert, bin aber grad nicht zuhause und komm nicht an die Datei. Ich werd die die Tage mal einstellen.

Das Problem ist, dass die .htaccess per default für recht offene Server geschrieben ist, und die Server hier im positiven Sinne schon restriktiv konfiguriert sind - da beißen sich die Einstellungen.
Problemlösungswahrsager, Glaskugelmethode

*

Offline driet

  • *****
  • 732
  • Volle Kanne, Hoschi!
    • Profil anzeigen
Re: Lesbare URLs auf Joomla100 nicht möglich
« Antwort #13 am: 24.08.2007 22:49 Uhr »
Mit angehängter Datei (muss natürlich in .htaccess umbenannt werden) läuft bei mir zumindest 5.1 ohne irgendwelche Mucken.

Grüße,

driet
« Letzte Änderung: 13.08.2009 17:42 Uhr von driet »
Problemlösungswahrsager, Glaskugelmethode

Re:Lesbare URLs auf Joomla100 nicht möglich
« Antwort #14 am: 13.08.2009 17:26 Uhr »
Wollt mal Danke an driet sagen, das löste auch mein Problem mit der 6.12 Version.
Auch da half ein einfaches ausklammern von:
#Options -Indexes
#Options +FollowSymLinks nicht,
nur umbennen der .htaccess half aber das wollt ich dann auch nicht  ;D