Beiträge anzeigen

Diese Sektion erlaubt es ihnen alle Beiträge dieses Mitglieds zu sehen. Beachten sie, dass sie nur solche Beiträge sehen können, zu denen sie auch Zugriffsrechte haben.


Nachrichten - JoLic

Seiten: [1] 2 3 ... 6
1
Hallo, nutze seit langem Roundcube - derzeit 1.3.6 mit Enigma welches seit V 1.2 in RC enthalten ist.
Bis zur Umstellung auf Plesk hatte das alles gut funktioniert, nun erhalte ich folgende Fehlermeldung:

Zitat
Application Error (600): Enigma plugin: GPG binary not found. If you are sure the GPG binary is installed, please specify the location of the GPG binary using the 'binary' driver option.

Frage1: Ist die GPG binary installiert?

Frage2: In den Settings von Roundcube kann man den Pfad zum gpg angeben (war bisher nicht notwendig).
$config['enigma_pgp_binary'] = '';Welcher wäre das dann? ('/usr/bin/gpg' hat nichts bewirkt)

Danke für jede Hilfe oder Tipp.


Nachtrag, evtl. hat das was mit dem open_basedir in Plesk zu tun? Aus dem Roundcube Log:
Zitat
PHP Warning:  is_executable(): open_basedir restriction in effect. File(/usr/bin/gpg) is not within the allowed path(s): (/var/www/vhosts/webXXX.frink.kundenserver42.de/:/tmp/)


GELÖST:
OK, Problem ist im Zusammenhang mit Plesk. Habs im RC-Forum gefunden: Plesk nutzt wohl "open_basedir restriction" ;-(
Habe in Plesk open_basedir auf none gesetzt und der Fehler ist weg.


2
Plesk-Kundenmenü / Re: Plesk mit LetsEncrypt
« am: 15.01.2018 18:59 Uhr »
Zitat
sorry Jolic für die späte Antwort! Ich dachte ich bekomme eine Mail, wenn eine Antwort reinkommt. Danke für die schnelle Antwort!
kein Problem, hast du die Checkbox "Bei neuen Antworten benachrichtigen" angeklickt?

Zitat
Die Limits pro Woche sind dann für den ganzen Server auf dem meine Seite läuft, also für alle Kunden die auf kundenserverXX laufen?
keine Ahnung -> Admin?

Vorweg: Ich kenne mich mit WP nicht aus, sehe aber diese "Schönheitsfehler" im Quellcode und daher ist manches nicht so grün wie es sein sollte  8)

Zitat
Spannend ist ja, dass die eingebundenen Bilder, die nicht über relative Pfadangaben eingebunden sind, sondern über "http://" jetzt mit einem grünen "https://" angezeigt werden. zB https://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg Liegt es daran, dass LetsEncrypt schon paar Zertifikate rausgegeben hat, und der Rest der Webseite mit der Zeit dann nachzieht?
nein, in deinem Quelltext steht z.B. "http://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg" und deshalb ist das Schloss auf deiner Startseite nicht grün. Wenn du dir das Bild anzeigen lässt, leitet der Server das zu HTTPS um (siehe Einstellung: "Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS"). Den Quellcode (was also dein WP parst) kann und darf LetsEncrypt nicht einfach ändern.

Zitat
Gerne füge ich auch die Base ein und mache dann die relativen Pfade. Welches Problem kann ich damit umgehen?
wenn du dich mit deinem Template nicht auskennst, lass es besser sein  ;)

Ich erstelle meine Templates selbst und weiß daher wo ich ansetzen muss.
An deiner Stelle würde ich im HTML-Quellcode die "http://" Bereiche suchen und dann die Ursache in deinem WP Backend beheben.
Da das kein Joomla100 oder LetsEncrypt Problem ist - könntest du nach Lösungen evtl. auch in WP Foren suchen?


jolic


3
Plesk-Kundenmenü / Re: Plesk mit LetsEncrypt
« am: 10.01.2018 20:52 Uhr »
Zitat
gültiges Zertifikat, aber https wird trotzdem nicht grün

Hi, sieht aus als ob dein WP den html-codes parst, z.B.:
src="http://fionn-gorilla.de/wp-content/uploads/2016/02/halloichbinfionn.jpg"oder
href="http://fionn-gorilla.de/ueber-mich/"
Kann mich auch irren, aber du nutzt keine relative Verweise?

Ich füge deshalb in meinen Templates immer eine base-Element ein und benutze nur relative Verweise.
Bei dir müsste dann im Template head ein
<base href="https://fionn-gorilla.de/">stehen. Dann könntest du relative urls benutzen z.B.:
src="wp-content/uploads/2016/02/halloichbinfionn.jpg"
Das passt dann immer  ;D

jolic

4
Ja, nun funktioniert ändern und löschen  :)

und nun diese blöde Wort "aber":
Der Backup-Manager ist nun leer und wenn ich ein Backup Planen möchte kommt der Fehler:
Nur der FTP-Speicher wird für Backups zugelassen. Die Einstellungen wurden jedoch nicht angegeben. Konfigurieren Sie den FTP-Speicher zuerst.
Update: Danke, nun funktioniert auch das Backup!
Besser als unter Confixx: inkrementell, planbar und bestimmte Dateien lassen sich vom Backup ausschließen (z.B. Cache-Dateien)


5
nein, alles beim alten

6
Hi, bestehende Subdomains oder Weiterleitungen die aus Confixx übernommen wurden lassen sich nicht löschen und "Hosting-Typ" kann ich nicht ändern.

Könnt ihr das bitte freischalten?

Wenn ich eine neue Subdomain oder Weiterleitung erstelle, kann ich diese löschen oder den "Hosting-Typ" ändern.


7
Hi, Joomla100 hat da was angepasst.

Probier mal: Webhosting-Zugang -> Zugriff auf den Server via SSH: "/bin/bash (chrooted)"

Dann sollte es per SFTP funktionieren.

8
Plesk-Kundenmenü / Plesk - Geplante Aufgaben
« am: 23.12.2017 00:45 Uhr »
Hallo Joomla100-Team,

bei Geplante Aufgaben (cronjob) ist mir aufgefallen das der Pfad (file location) sich nach der Umstellung geändert hat.
Anstatt "html" ist es nun "httpdocs" und ich musste meine htaccess-Dateien für passwortgeschützte Bereiche anpassen.

Im Plesk wurde auch ein cronjob aus Confixx importiert (siehe Bild).



Die erste Line stammt aus Confixx und ist nun falsch. Habe daher eine neue Aufgabe hinzugefügt (2te Linie).

Eventuell könnt ihr das bei der nächsten Umstellung anpassen?


9
Plesk-Kundenmenü / Re: Plesk mit LetsEncrypt
« am: 23.12.2017 00:11 Uhr »
Das ist ja wirklich Gold gegenüber Confixx...

So ist es  8)

Falls sich jemand wundert:
Plesk legt in der Domain temporär den Ordner .well-known an. Dort befinden sich die zur Validierung des SSL-Zertifikats nötigen Daten.

10
Plesk-Kundenmenü / Re: Plesk mit LetsEncrypt
« am: 21.12.2017 21:29 Uhr »
mhh, in der linken Navigation habe ich nun ein "Security Advisor", damit scheint es zu gehen. Teste das...

Bingo, so funktioniert es.

Danke!

11
Plesk-Kundenmenü / Re: Plesk mit LetsEncrypt
« am: 21.12.2017 21:24 Uhr »
Leider nein, sehe aber das im Konto -> Zusätzliche Services der Schalter "Let's Encrypt" nun aktiviert ist.

Es kommt immer noch diese Warnung und kein Assistent.

12
Plesk-Kundenmenü / Plesk mit LetsEncrypt
« am: 21.12.2017 20:59 Uhr »
Hi, eine Frage zum neuen Plesk und LetsEncrypt-Zertifikat.

Wenn ich auf "Let's Encrypt" klicke kommt anstatt dem Assistenten nur diese Meldung:
Warnung: SSL/TLS support is disabled for malbergweich.de.
To resolve the issue, please enable to SSL/TLS support ("Websites & Domains" > "Hosting Settings") for this domain and try again.

In den Hosting-Einstellungen ist SSL/TLS-Unterstützung aus und lässt sich nicht aktivieren.

Unter "Konto" und "Zusätzliche Services" ist der Schalter "Let's Encrypt" aus und lässt sich auch nicht aktivieren.

Fehlt da noch die Freigabe dazu?

Gruß jolic

13
Plesk-Kundenmenü / Re: https unsigniert und Plesk Zugang?
« am: 21.12.2017 20:36 Uhr »
OK Danke, der Link zu Plesk funktioniert nun (heute Mittag ging da noch nichts).

Ja LetsEncrypt habe ich auf einem anderen Server auch am laufen. Schau mir das im Plesk mal...

Danke jolic

14
Hi, kann ich bestätigen.
Funktioniert nur mit FTP, jedoch nicht mehr mit SFTP  ???

15
Plesk-Kundenmenü / https unsigniert und Plesk Zugang?
« am: 21.12.2017 10:51 Uhr »
Hallo Joomla100-Team,
meine Seite ist seit heute Morgen wieder online  :)

Was derzeit noch nicht funktioniert ist:
  • MODX Backend (manager) Zugang per https unsigniert - sollte doch auch mit Plesk funktionieren?
  • Der Confixx Zugang war "secure.apu.kundenserver42.de", ist das bei Plesk genau so? (derzeit keine Verbindung)

Gruß jolic

Seiten: [1] 2 3 ... 6